Any Color You Like
Icon Themes
Score 79%
Description:

After installing the theme like any other, run the script with this command:
cd ~/.icons/ACYL_Icon_Theme_0.9.4/ && bash AnyColorYouLike

A monochrome icon theme that comes with a script to modify the icons.


I develop this icon theme on my free time because I find it interesting. But if you appreciate it and want to give something back, consider donating via paypal using the donate button.
Last changelog:

6 years ago

* 0.9.4 2011-08-27
- 3 new filters: Orb, Grungy and Splatter.
- A few more icons.
- Bodhi logo added.
- New trash icon.
- Minor bugfix.
- Icons should now work with the qt svg renderer.

* 0.9.3 2011-01-15
- 150+ new icons, most from the clarity theme.
- Folders from web0.
- 3 new filters: Quadratic, Bevel and Outline.
- Text based interface dropped.
- Some GUI changes.
- Automatic offset option.
- Some changes to the svg structure.
- Checkboxes for apply settings.
- One or two bugs fixed.
- Included instructions for translation.

Svento

1 year ago

Not sure I understood this correctly, but isn't the idea being able to change the color of the theme? In that case: How do I actually do that? Change the color of the icons?

Report

swordplay

3 years ago

Great theme!

If you can't come back to it, could you write a tutorial on how to add to it and how it works?

Aloha,

m a r

Report

C

switzak

3 years ago

I have always intended to release at least one more version but I have not managed to make time for this project. I wrote a quick guide in this deviantart comment on how to add new icons to the theme. http://comments.deviantart.com/1/175624910/2430631013

Report

strungoutfan78

4 years ago

Would it be possible to add a sunbird/iceowl icon? It's the only thing standing between me and my perfect desktop now. Again, thanks for the awesome work. I'll be donating for sure.

Report

C

switzak

4 years ago

This project have been on hold for some time. However I'm considering working on it again soon.

These are calendar programs right? A quick fix could be just make a copy of the calendar.svg icon in ~/.icons/ACYL_Icon_Theme_0.9.5/scalable/apps/ and name it correctly.

A tip for finding the correct name of the icons is locating them in the /usr/share/icons/hicolor/apps/ folder and see what name they have there. Works most of the time.

Report

strungoutfan78

5 years ago

What's the proper name of this theme to add to my .gtkrc-2.0.mine? I've tried both AnyColorYouLike and ACYL. Neither one works. Using gnome-appearance-propeties has no effect either.

Report

C

switzak

5 years ago

I don't know how that works so I can't say anything for certain but you could give ACYL_Icon_Theme_0.9.5 a shot as that is the name of the folder. Good luck!

Report

strungoutfan78

5 years ago

Hmmmm. I always thought that the name came from the "Name=" line in the index.theme file, which in this case is AnyColorYouLike, but it doesn't seem to work. I'll try your suggestion. Thanks. Love your theme and hope I can get it working.

Report

br00t

5 years ago

I have been using this icon set for a few months and
I love it. The only problem Ive had is with the geany terminator and dropbox icons, for some reason those three icons will not change. Do you know where geany, terminator and dropbox store their icons?

Report

C

switzak

5 years ago

All three of them works without a problem for me. The icon location might be different for other versions of the programs in which case I don't know it.

Report

pissnaround

5 years ago

I'm trying to install ACYL in ArchBang but the script is failing with a syntax error. I think it said in line 7. I'm just using the default openbox DE.

any thoughts?

Report

C

switzak

5 years ago

What does it say exactly? And what version of python do you have?

Report

pissnaround

5 years ago

it says...
File "/home/louis/.icons/ACYL_Icon_Theme_0.9.4/scalable/scripts/script_gui.py", line 7
print "You do not have the gconf module installed, however it is optional."
^
SyntaxError: invalid syntax
and it's python 3.2.2

Report

C

switzak

5 years ago

The script does NOT support python 3.xx. I think it would work if you install version 2.6 or a higher 2.xx. It should not be any problem having two version of python at the same time, but I recommend you look it up to see if there is something special that needs to be done.

If you do decide to install python 2.x you might have to tell the script what version it should use.
And here is a mini-guide on how to do that:
* Find the file script_gui.py in ~/.icons/Any_Color_You_Like_0.9.4/scalable/scripts/
* Edit the first line in a text editor, it should be something like #!/usr/bin/env python2.x when you are done. Where python2.x should match the version you have installed.

Report

pissnaround

5 years ago

it might but since it's the only distro I'm having an issue with I think I will leave it alone. not sure I want two pythons installed anyway. :)

thanks for the info though :D

Report

C

switzak

5 years ago

Heh, I just noticed from some older comments that you have changed versions in the script before so the last part of my previous post is somewhat redundant. But I guess it could be good for other people with similar problems. =)

Report

pibarnas

5 years ago

Even changing #!/bin/python to #!/bin/python2.7 (which is installed on my Lubuntu 12.04, I keep getting these errors when running AnyColorYouLike:

You do not have the gconf module installed, however it is optional.
Some dependencies are missing!
The following ones are required:
gtk, gtk.glade, sys, os, subprocess,
shutil, gettext, ConfigParser
Traceback (most recent call last):
File "/home/pibarnas/.icons/ACYL_Icon_Theme_0.9.4/scalable/scripts/script_gui.py", line 23, in <module>
sys.exit(1)
NameError: name 'sys' is not defined

Wouldn't be a good idea to provide a list of deps somewhere in order to the user install them?

Report

C

switzak

5 years ago

Well, the script depends on the python modules listed in the error text. I don't know which packages they all originate from. But most of them should be pretty standard and come with an installation of python.

You should have the "sys" module if you have installed python. I have no idea why you get an error, although I have gotten this reported to me once before. It was on a fresh install of ubuntu 11.10. That time it seemed to solve itself after a reboot. Sorry I can't be of much help.

Report

switchrodeo720

6 years ago

I had been using this theme then I upgraded to Ubuntu 11.10. Now when I try to apply a new style, the terminal out puts "gnome-panel: no process found". I'm not sure if there's something I should be doing differently or not. Please let us know. Thanks.

Report

switchrodeo720

6 years ago

Nevermind...complete fail on my part. There's no issue.

Report

ilnanny75

6 years ago

Hey Thanks for sharing your awesome work!!
I like this :D
Thanks Man :]

Report

coreman

6 years ago

This theme was just what I needed to make this: http://gnome-look.org/content/show.php?content=143075
My computer looks a lot more awesome now, thanks!

Report

C

switzak

6 years ago

Good to hear you like them! Your gtk theme looks similar to my own, but I guess thats because we both use the HC engine. =)

Report

Kamiel

6 years ago

Please, add
ln -s scalable/status/network-idle.svg scalable/real_icons/status/connect_established.svg

Thx!

Report

luka70

6 years ago

marvellous job! :D
IMHO it would be greater if you put an option in "any color you want" for an outer shadow/outer glow...
do you think it would be possible?

Report

6 years ago

* 0.9.4 2011-08-27
- 3 new filters: Orb, Grungy and Splatter.
- A few more icons.
- Bodhi logo added.
- New trash icon.
- Minor bugfix.
- Icons should now work with the qt svg renderer.

* 0.9.3 2011-01-15
- 150+ new icons, most from the clarity theme.
- Folders from web0.
- 3 new filters: Quadratic, Bevel and Outline.
- Text based interface dropped.
- Some GUI changes.
- Automatic offset option.
- Some changes to the svg structure.
- Checkboxes for apply settings.
- One or two bugs fixed.
- Included instructions for translation.

product-maker kevin-leptons Nov 24 2016

product-maker dadmig Oct 08 2014

product-maker xMaki Dec 10 2012

product-maker lordvecna Nov 03 2012

product-maker virush Aug 10 2012

product-maker leonardoroza May 04 2012

product-maker TheRob Mar 01 2012

product-maker Broker Feb 05 2012

product-maker nale12 Nov 14 2011

product-maker MiShUbuntu Aug 27 2011

product-maker kbmonkey Aug 18 2011

product-maker coreman Aug 09 2011

product-maker melm Jul 19 2011

product-maker joplass Jul 18 2011

product-maker bingyuan Jun 14 2011

product-maker aneeszaki Jun 11 2011

product-maker luka70 May 09 2011

product-maker eXeS Mar 12 2011

product-maker theZoid Feb 23 2011

product-maker cippaciong Feb 17 2011

product-maker silverkeeper Feb 06 2011

product-maker aulait Jan 21 2011

product-maker ubuntico Jan 16 2011

product-maker gravy Jan 16 2011

product-maker nhianho Jan 16 2011

product-maker thimoteus Jan 15 2011

product-maker tobaj Jan 15 2011

product-maker Kamiel Jan 01 2011

product-maker yaseen Dec 29 2010

product-maker Ahmose Nov 27 2010

product-maker Pyruzan Nov 24 2010

product-maker dotNet Nov 17 2010

product-maker nfn6789 Nov 15 2010

product-maker vkos Nov 14 2010

product-maker likimoki Nov 09 2010

product-maker disastrophe Nov 08 2010

product-maker dragonfi Oct 18 2010

product-maker neolid Oct 10 2010

product-maker lkonti Oct 09 2010

product-maker escortgoj Oct 06 2010

product-maker untouchable89 Oct 05 2010

product-maker balakrishnan Oct 05 2010

product-maker Alex45 Oct 03 2010

product-maker beresk137 Sep 23 2010

product-maker 38 130

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.9.4
updated Aug 26 2011
added Apr 08 2009
downloads today
page views today