Google Calendar Screenlet
Conky
Score 62%
Description:

Adds Google Calendar events on your desktop. Supports any amount of different calendars, updates automatically and has many configuration options. Themeable and lightweight.

EASY INSTALL FOR UBUNTU

1. If Screenlets PPA is not already enabled on your system, either from software sources manager or terminal add ppa:screenlets-dev/ppa to the list of software sources (see http://www.screenlets.org/index.php/Download for help).

2. Refresh package list and install googlecalendar-screenlet from your favourite package manager or by clicking automatic installation link provided below.

If you don't use Screenlets PPA you have to manually install python-gdata package 2.0.10 or later (see http://code.google.com/p/gcalscreenlet/wiki/Installation for further instructions).

MORE ABOUT THE SCREENLET

Notice, that you can import basically any local or remote ICS calendar through your Google account. Since calendars are parsed by Google Data API, the representation of data should be highly accurate.

You can help to translate the Screenlet to your language at https://translations.launchpad.net/indiv-screenlets/trunk/+pots/googlecalendar-screenlet/.

You can submit fixes or enhancements for the Screenlet at https://launchpad.net/~indiv-screenlets-dev.

Please feel free to submit any new themes for the screenlet!
Last changelog:

6 years ago

0.4.9 Easy install from PPA etc

* Added gCal to the new official Screenlets PPA
* Added DIY overkill for customizing event list

0.4.8 Enhancement

* Custom time formatting

0.4.7 Themework

* Cleaned up the themes
* Added Ambiance theme by Denis Å andor

0.4.5 Improvements

* Font options fixed in spite of Screenlets framework bugs
* Added configurable labels for tomorrow/day after tomorrow
* Supplied example theme under name "Childish" (use with caution, because it overrides your precious font settings for the screenlet)

0.4.2 Bugfixes

* "Today" string will be updated immediately

0.4.1 Bugfixes

* Updating will survive internet connection failures
* Long lasting events from previous days not displayed
* Some more error feedback for users with problems

0.4.0 First release.

* Errors seem to be fixed.
* Works reasonably well.

7min

3 years ago

I installed the latest version from PPA this afternoon, and all is working properly, except when I activate a Google Sports Calendar for one of my local teams.

For example, in your google calendar on the web, go to "Other Calendars" on the bottom left of the screen. Then select "Browse Interesting Calendars" and then select "Sports". I selected Hockey, then National Hockey League, then pick any team.

The calendar on the web will update automatically with new events, but the Linux desktop will not update. If you right-click the calendar on the desktop and force the screenlet to update, the events *still* will not show up, but now all of your old events will be completely out of order (and I can't figure out what order they're in. They're not sorted by time, or date, or alphabetically) but as soon as you remove the sports calendar, and force a refresh of the screenlet, they'll be in the proper order again.

Report

toupaclop

5 years ago

I like this screenlet and it works very well. But one thing doesn't work as it should : is the position on the screen. I put it in the upper left corner (x=5 and Y=50) and after 3 or 4 boots, it comes back to is default position (center). How can I fix this ?

Report

boamaod

5 years ago

Are you using latest 0.1.7 of screenlets?

Report

toupaclop

5 years ago

Thank you for your reply.
No, I have the 0.1.6 available with xfce voyager 12.04.
If my problem can be fix by an upgrade, where I can find it ? The .deb here for example : https://launchpad.net/~screenlets-dev/+archive/ppa/+build/3583737 ?

Report

boamaod

5 years ago

Yes, I suggest you try ppa:screenlets-dev/ppa

You can find directions at http://screenlets.org/index.php/Download

However I have not not tested Screenlets much on XFCE.

Report

toupaclop

5 years ago

I have upgraded screnlets, then I have booted a dozen and it is always at the right place.
thank you a lot!

Report

locoguano

5 years ago

The screenlet loads, appears for about 2 seconds, then disappears.
Running Ubuntu 12.04.

Any ideas?

Report

boamaod

5 years ago

If you run it from command line and get some error messages, we could maybe do something about it.

I suppose it is something like:

python /usr/share/screenlets/GoogleCalendar/GoogleCalendarScreenlet.py

Report

Jogimoto

4 years ago

Hi, i've got the same problem as the user above: Google Calendar loads and diappears.

By starting it over the command line i've got the following error message: "TypeError: integer argument expected, got float"

I am also using ubuntu 12.10. I would really like to use it. Any idea?

Report

zeebout

3 years ago

I also got the same error. Anybode knows how to fix this?

Report

MortusAllen

5 years ago

This is great! Does exactly what I have been look for a screenlet to do! That being said I am getting an error when it starts up that states the following.

Requirements for the Screenlet are not satisfied! Use the package manager of your system to install required packages.

REQUIREMENTS:

python-gdata Ins2.0.14-2 installed, req 2.0.10.

As you can see I have a newer version then the required version. This does not seem to impede the function of the screenlet though other than it does not appear to remain where I placed it.

Report

boamaod

5 years ago

Please confirm, that the message appears with latest Screenlets from Dev PPA. If so, pleast tell the exact versions you are using (screenlets and googlecalendar).

And I believe you can override the Debian version from screenlet options, so the message won't display.

Report

MortusAllen

5 years ago

I appear to be using the latest versions available from the Dev PPA and still getting the message.

Screenlets version is 0.1.6
Google Calender version is 0.4.16

I am also running Ubuntu 11.10 if that helps or makes any difference.

Report

boamaod

5 years ago

What locale do you use? If you run screenlets with default locale like "LANG=C screenlets-daemon" does the bug appear?

I have the same versions on Ubuntu 11.10 and don't have the problem. However there are some calls to apt-cache and dpkg which are parsed from CLI, locale may affect the parser. These are in /usr/share/pyshared/screenlets/__init__.py. If you want, you may try if adding LANG=C in front of those calls helps. I mean like "commandstr = 'LANG=C apt-cache ...

Report

vfede

5 years ago

Same problem here on Mint 12. The init_py is like you said, with LANG=C stuff already in.

Please fix or suggest a way I can fix it, thanks:)

Report

boamaod

5 years ago

There was a bit too crazy grepping algorith which didn't seem to work. I committed updated version to Dev PPA couple of seconds ago. See if it fixes the problem.

Btw, you can always select "Ignore dependencies" from each screenlet config, this should fix it anyway.

Report

vfede

5 years ago

Wow, fastest developer ever, thanks.
I installed from the "Automatic install from Screenlets PPA" link in this page and now it works!
Many thanks!

Report

dl1dby

5 years ago

Same problem here. I had a "&" as text in an google calendar entry and the screenlet didn't show any entries. I replaced the "&" with an "and" and all entries in the screenlet were back again.

Report

boamaod

5 years ago

Did you try the version from https://launchpad.net/~screenlets-dev/+archive/ppa? I hope the problem is fixed there.

Report

mntnbiker

5 years ago

For starters, let me say this is a great screenlet and I love it!

I had the same problem that others have had, where the screenlet appeared to be working fine except no events were showing up. I made sure my python-gdata ppa was correct, and upgraded, and also re-installed the screenlet several times with no luck.

I eventually found the following error in my GoogleCalendarScreenlet.log file:
"/usr/share/screenlets/GoogleCalendar/GoogleCalendarScreenlet.py:1407: PangoWarning: pango_layout_set_markup_with_accel: Error on line 7: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &
self.p_layout.set_markup(text)"

I then found that one of my calendar events had an ampersand (&) in it, so I changed the "&" to the word "and", in that one event, and then all of my upcoming events appeared in the screenlet.

I hope this helps somebody else.

Report

boamaod

5 years ago

Tried to fix it in GoogleCalendar 0.4.16 in indiv screenlets branch revision 1101 http://bazaar.launchpad.net/~indiv-screenlets-dev/indiv-screenlets/trunk/revision/1101 which should be available in Screenlets Dev PPA in next 24h.

Report

francescoufondfdp

5 years ago

Hi,
Thank for this wonderful screenlet. I've just a question (sorry for my bad english). It is possible to choose calendars ? I have a lot of calendars and I don't want to see all of them.
If there is a solution...
fdp

Report

boamaod

5 years ago

I don't know if that satisfies you, but you can choose which calendars to show on Google Calendar site itself. Doesn't this work?

Report

francescoufondfdp

5 years ago

Yes, it works only if you hide the calendar. But not if you only uncheck the calendar...Strange?!

Report

nmhdias

6 years ago

doesn't seem to work with gnome3. Anyone?

Report

6 years ago

0.4.9 Easy install from PPA etc

* Added gCal to the new official Screenlets PPA
* Added DIY overkill for customizing event list

0.4.8 Enhancement

* Custom time formatting

0.4.7 Themework

* Cleaned up the themes
* Added Ambiance theme by Denis Å andor

0.4.5 Improvements

* Font options fixed in spite of Screenlets framework bugs
* Added configurable labels for tomorrow/day after tomorrow
* Supplied example theme under name "Childish" (use with caution, because it overrides your precious font settings for the screenlet)

0.4.2 Bugfixes

* "Today" string will be updated immediately

0.4.1 Bugfixes

* Updating will survive internet connection failures
* Long lasting events from previous days not displayed
* Some more error feedback for users with problems

0.4.0 First release.

* Errors seem to be fixed.
* Works reasonably well.

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.4.9
updated Nov 29 2010
added May 27 2010
downloads today
0
page views today 0