Usplash Theme - Fingerprint
Usplash Themes
Description:


This work is outdated. Please check my new theme at
http://www.gnome-look.org/content/show.php/Asufi+High+Tech+Usplash+Theme?content=98360




PROJECT IS NOW HOSTED AND SUPPORTED BY SOURCEFORGE. MANY THANKS TO THE STAFF.

SourceForge HomePage:
https://sourceforge.net/projects/u-fingerprint

WebSite HomePage
http://u-fingerprint.sourceforge.net/


USEFUL INFORMATIONS:

Now you can choose your Architecture from release page, after clicking download. In last release (signed with 'current') you can also find sources package.


CVS SOURCES

For cvs access to sources please use the command

cvs -d:pserver:anonymous@u-fingerprint.cvs.sourceforge.net:/cvsroot/u-fingerprint co u-fingerprint u-fingerprint


FEATURES:

- Two Charging bars instead of just one
- Works with resolutions up to 1280x1024
- Works with amd64 arch, even with ubuntu bug (for feisty/edgy)
- Each file contains a ReadMe with full installation instructions (from beta 4)
- PPC support from version 0.1 Stable
- Now with CVS access to sources

Just for 0.2 Alpha versions
- Possibility to use non-quiet mode and display text
- Cohorinated text/bagkground/foreground color of the text box to the theme
- Not using default font in text box
- Improved lighting (soon will be 3d) effect on the progressbar


CREDITS:

This a modification of the theme for bootsplash named 'Fingerprint' , released on kde-look.org under GPL. You can find original work here:

http://www.kde-look.org/content/show.php?content=29662


GUIDES and HOW-TOs:

Each file from 0.1 beta 4 contains a ReadMe with full instructions.

Documentation is also present in SourceForge site

INSTALLATION HOW-TO

[ENG] https://sourceforge.net/docman/display_doc.php?docid=40914&group_id=187765
[ITA] https://sourceforge.net/docman/display_doc.php?docid=41205&group_id=187765
[FRENCH] https://sourceforge.net/docman/display_doc.php?docid=42859&group_id=187765

CVS HOW-TO

[ENG] https://sourceforge.net/docman/display_doc.php?docid=42366&group_id=187765


TODO:

- Working on new effects on the progress bar. I want to create a 3d Effect.
- Compile fot PPC and Amd64 (I'll do it from the first beta)


THANKS

Many thanks go to Burrodomo and Squeeonline who helped me in finding and fixing bugs.
I also would like to thank so much Divilinux from Italian Ubuntu Support Forum, who compiled stable package for PPC Arch.


WHAT ABOUT ALPHA VERSION

Even if the 0.2 Alpha 1 was released I suggest common user to continue choosing the 0.1 Stable version just to be sure to see you booting process next time you turn-on you PC :D


LATEST NEWS

0.2 Alpha 1 Released !
Last changelog:

9 years ago

0.2 Alpha 1

Added possibility to use non-quiet mode, displaying booting text. Improved progressbar effects.

0.1 Stable
Added PPC support

This is the final release for this version. This means that this won't be updated anymore. Future bugs will effect only next release (0.2)

0.1 RC 1
Added 1280x1024. Fixed ALL bugs for i386 version. Reviewed Description. Changed string from 'on the world' to 'in the world'. Updated sources.

0.1 beta 4
Added ReadMe in each file, updated sources, recompile to fix other visualization bugs

0.1 beta 3
Fixed problems of visualization of bars with i386. Amd64 works well with beta2

0.1 beta 2 -1
Fixed problem with wrong architecture for i386

0.1 beta 2
Changed from 'Press F2 for Verbose Mode' To 'Press ALT+F1 for Verbose Mode'

0.1 beta 1
Added a second bar in the top,now you got 2 bars charging toghether!

0.1 alpha 3
Released amd64 version (for edgy/feisty problems). Changed names of themes, Changed Guide in this page.

0.1 alpha 2
Improved the progress-bar graphic

0.1 alpha1
The Beginning

appzattak

9 years ago

Would be greatly appreciated!!!

Report

Embrace

9 years ago

Everyone who got the black box issue due to non-quiet utilize of usplash please try new Alpha2 release and feed me back here or on sourceforge forum.

Thanks evberybody.

Report

justananomaly

9 years ago

WORKED!
Heres how I did it:
Saved the 0.2 Alpha 1 to my desktop
Unpacked, moved the .so from the unpacked folder to the desktop
Open Terminal (You can skip the first line if you've already had the old version installed):
sudo cp usplash-theme-fingerprint.so /usr/lib/usplash
sudo update-alternatives --install /usr/lib/usplash/usplash-artwork.so usplash-artwork.so /usr/lib/usplash/usplash-theme-fingerprint.so 10
sudo update-alternatives --config usplash-artwork.so
sudo update-initramfs -u
Rebooted
While it was shutting down the blackbox was there, when I was booting up it worked perfectly however!

Report

Embrace

9 years ago

Nice! Thanks for feeding back! I hope the problem has been solved for everybody so that we can go on with other implementations.

Report

thematic

9 years ago

Unfortunately not for me, still getting annoying black box!!!!

Report

daaxix

9 years ago

I just installed this, I am running Ubuntu 7.10, I followed the instructions exactly, and I still get the black box and the normal Ubuntu splash login screen after the grub screen. Is this normal (the normal Ubuntu login screen)? I have an Intel Core 2 duo, so AMD bug is not applicable. I know this is free software, so not complaining too much, the screen looks awesome though! I would very much like to use it and I am not going to take the time to recompile directly. I have the splash manager installed, maybe that is a problem?

Report

stickboy3k

9 years ago

I've added the vga=791 and now it attempts to load at 1440x900 (macbook pro), however i get the error "Usplash no suitable theme found for 1440x900" so i get basic text mode boot.
Thanks

Report

Embrace

9 years ago

That resolution is not supported. Please use the 1024x768. I'll try to make a widescreen version with the new released, but as I don't have a widescreen I can not test it and building became hard.

Report

thematic

10 years ago

No text seen only black box..

tried everything suggested(added vga=791), but when I check..

sudo usplash -c

then it come with black box.. and terminal shows..

usplash: Setting mode 1024x768 failed
usplash: Using mode 800x600

rebooted, but the problem persists.. how to resolve it??

Using Ubuntu fesity, 2.6.20-16
thanks

Report

Embrace

10 years ago

You should check the guide

https://sourceforge.net/docman/display_doc.php?docid=40914&group_id=187765


It is explained that you should run the command

sudo update-initramfs -u

which is valid for the most debian-based distribution

If your distr does not support init i don't knowwhat to suggest you

Report

uzi09

10 years ago

i followed the instructions exactly, but to no avail.
however, i did mess around with the settings a bit (i think i basically renamed the old splash so that it may not be able to read it), at first it didn't make a difference, but after a restart or two, this splash shows up for both startup and shutdown. there is still one problem remaining, a big black block where the the rectangle is :S. just gotta get that sorted.

Report

uzi09

10 years ago

k, tried everything again, however it looked like my ubuntu got updated and changed some settings around (ex: the vga was missing again for some reason), so i did it, restarted and it seems to work.

thanks for any help

Report

parasyte

9 years ago

I see there are several posts about this black box issue and I had the same problem but found a solution that works for me on Ubuntu (Fiesty Fawn).

First off, be sure to have a correct "kernel" line in your menu.lst (from /boot/grub directory most likely). Mine looks like this:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=b415c32e-f248-4b49-a225-94340f2cb8f6 ro quiet splash locale=en_US vga=791

Note that I'm using en_US for locale but your milage may very. Also note that the word 'quiet' is in there -otherwise usplash will expect a proper text area.

Having 'quiet' in the kernel line doesn't make the text box go away for me though. So on to the source code (file usplash-theme-ubuntu.c):

In the sources, change the color codes. I used the libusplash-dev example scheme for this. So in the structure usplash_theme_1024_768, for instance, I changed this:
/* Palette indexes */
/* parasyte - these colors are broken
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x0,
.text_foreground = 0x156,
.text_success = 0x15,
.text_failure = 0x144,
*/

to this:
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x31,
.text_foreground = 0x15,
.text_success = 0x171,
.text_failure = 0x156,

rebuilding the project and following the normal install procedures now works fine. I've also done some other customizations like moved the box over the text area and turned of quiet but that is info for another time.

-parasyte

Report

parasyte

9 years ago

I see there are several posts about this black box issue and I had the same problem but found a solution that works for me on Ubuntu (Fiesty Fawn).

First off, be sure to have a correct "kernel" line in your menu.lst (from /boot/grub directory most likely). Mine looks like this:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=b415c32e-f248-4b49-a225-94340f2cb8f6 ro quiet splash locale=en_US vga=791

Note that I'm using en_US for locale but your milage may very. Also note that the word 'quiet' is in there -otherwise usplash will expect a proper text area.

Having 'quiet' in the kernel line doesn't make the text box go away for me though. So on to the source code (file usplash-theme-ubuntu.c):

In the sources, change the color codes. I used the libusplash-dev example scheme for this. So in the structure usplash_theme_1024_768, for instance, I changed this:
/* Palette indexes */
/* parasyte - these colors are broken
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x0,
.text_foreground = 0x156,
.text_success = 0x15,
.text_failure = 0x144,
*/

to this:
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x31,
.text_foreground = 0x15,
.text_success = 0x171,
.text_failure = 0x156,

rebuilding the project and following the normal install procedures now works fine. I've also done some other customizations like moved the box over the text area and turned of quiet but that is info for another time.

-parasyte

Report

Embrace

9 years ago

Hi! I Tried what you said but I believe it's not a problem of colours but insteat of dimension and position of the box...as i moved it now the theme will work...however I'll make more tries changing colours too.

Thank you for your segnalation!!!

Report

parasyte

9 years ago

cool! I'll check it out later today. This inspired me to attempt to make one of these on my own as well. I learned that it isn't so easy..... :D

also, sorry about the duplicate post back there -it was a result of a refresh.

Report

Embrace

9 years ago

I saw your project it seems good i tried it on virtualization!

NP for the double post who cares :D

I'm glad you try to create your own theme! Keep it up :D

Report

disz

9 years ago

Parasyte:
I made the adjustments you'd suggested, but I'm getting a compile error. Output below:
make: Circular throbber_back_640_400.png <- throbber_back_640_400.png.c dependency dropped.
pngtousplash throbber_back_640_400.png > throbber_back_640_400.png.c
gcc -g -Wall -fPIC -o throbber_back_640_400.png.c.o -c throbber_back_640_400.png.c
In file included from throbber_back_640_400.png.c:2:
/usr/include/usplash-theme.h:24:23: error: sys/types.h: No such file or directory
/usr/include/usplash-theme.h:25:20: error: stdlib.h: No such file or directory
In file included from throbber_back_640_400.png.c:2:
/usr/include/usplash-theme.h:77: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/usplash-theme.h:79: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/usplash-theme.h:93: error: expected specifier-qualifier-list before ‘u_int32_t’
make: *** [throbber_back_640_400.png.c.o] Error 1
rm throbber_back_640_400.png.c


Any idea what's up there? I'm on a fresh install of Gutsy (amd64).
-D.

Report

disz

9 years ago

Disregard that last one...I've just done a fresh install on a new machine and forgot to add build essentials. *LOL*

No worries.

Report

uzi09

10 years ago

first of all --- very cool splash

second -- unfortunately, it doesn't work :( (lol, jk)

no, but seriously, for some reason, it'll work only when my computer is shutting down (using ubuntu feisty), but when it's starting up, the ubuntu splash is still there.

any help is much appreciated

Report

humpty-d

10 years ago

I saw that many have a problem with text (a black screen over it). I had it too, so I post here my solution. It's very easy: you must add the string vga=791 at your menu.lst, at the end of the line "kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda5 ro quiet splash locale=en_EN".
This operation MUST BE YOUR LAST ONE (don't run any dpkg-reconfigure linux-image after it).
hope it will work for you all.
by

Report

lionroar

10 years ago

Tried what you said it di not work.

Report

lionroar

9 years ago

Okay I visited the download that I down loaded once before and it turned out the this one has more pictures that the last stable one that I downloaded did not have the stuff that the current one has. I bet that is what has been going on. The previous down load did not have all the required stuff. The funny thing is the the package source does not have the installion instructions like the previous one just an install file. Should I using the same instructions as the previous one.

Report

Neo4

10 years ago

I have Linux Mint (ubuntu Feisty mod)
and I followed the tutorial and nothing changed... the splash screen is still the first one...

any help?

Report

dunnix

9 years ago

I have this exact same problem on mint... Any help would be awesome.

Report

9 years ago

0.2 Alpha 1

Added possibility to use non-quiet mode, displaying booting text. Improved progressbar effects.

0.1 Stable
Added PPC support

This is the final release for this version. This means that this won't be updated anymore. Future bugs will effect only next release (0.2)

0.1 RC 1
Added 1280x1024. Fixed ALL bugs for i386 version. Reviewed Description. Changed string from 'on the world' to 'in the world'. Updated sources.

0.1 beta 4
Added ReadMe in each file, updated sources, recompile to fix other visualization bugs

0.1 beta 3
Fixed problems of visualization of bars with i386. Amd64 works well with beta2

0.1 beta 2 -1
Fixed problem with wrong architecture for i386

0.1 beta 2
Changed from 'Press F2 for Verbose Mode' To 'Press ALT+F1 for Verbose Mode'

0.1 beta 1
Added a second bar in the top,now you got 2 bars charging toghether!

0.1 alpha 3
Released amd64 version (for edgy/feisty problems). Changed names of themes, Changed Guide in this page.

0.1 alpha 2
Improved the progress-bar graphic

0.1 alpha1
The Beginning

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install
Score 77%
77.00 Likes
23 Dislikes
Details
version
0.2 ALPHA 1 !
updated Jun 29 2007
added Dec 20 2006
downloads
page views 3583