Compiz Experimental Plugins U/D 3-18-12

Compiz Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

14
Score 82.1%
Description:

Note these are experimental I have used them for some time with no issues.
32 and 64 bit !
For compiz 8.x will work in compiz 9.x! UPDATE !

>> FIND YOUR COMPIZ VERSION
compiz --version
Last changelog:

8 years ago

Credit goes to original author!
Scott Moreau oreaus@gmail.com
Thanks!
1.1 Corrected misplaced command.

1.2 ADDED Compiz dependencies!

2.0 Completely new script! I just tried it on my 32bit Lucid and had no issues!!If any errors come up while installing run ./compiz-addons install all nohup compiz --replace & again!
Try it and let me know! Sorry for any inconvenience!
Spread out commands,
Added credits and comment

2.1 Added script and how to to download link.And I hope it works for all!

2.2 Added Atlantis and 3D-Cube Model

3.5 for 11.++ And 12.++
new D/L for you

4.0 Cleaned up scripts and added support for compiz 8x & 9x in separate scripts !

4.5 Added Galaxy live wallpaper !
by ilap ! Thanks!! for maverick,natty, oneiric and precise!

Add this ppa to your source list, and take a tripp in to the Galaxy !!

2-4-12 added how to compile Galaxy live wallpaper for lucid.
Thanks for the heads up modal1 !

Update 3-17-12 5.0
uncommented jcanimations,wizard,gost simple animations and experimental animations, NOW, All plugins should work in compiz 9.4, BUT some will not be installed in compiz 9.7 Presice ! as the animation dependancy has not been updated in 9.7 ! They have A LOT of work to do to compiz to make it work right ! AGAIN These plugins are EXPERIMENTAL ! They work best in Gnome fallback, but do work in unity,Oneiric compiz 9.4 both with and with out the cube, at this point 9.7 has no cube ! and Many bugs, Be carefull !

Update 3-18-12
>> HOW TO UNINSTALL THESE PLUGINS
./compiz-addons uninstall all

If you installed Gallaxy, and want to remove it, Open synaptic, and search galaxy live wallpaper, mark for complete removal

giovanicascaes

9 years ago

Hi!

I'm getting this error:

Initialized empty Git repository in /home/giovani/src/compiz/plugins/wizard/.git/
remote: Counting objects: 31, done.
remote: Compressing objects: 100% (29/29), done.
remote: Total 31 (delta 9), reused 0 (delta 0)
Receiving objects: 100% (31/31), 40.88 KiB | 18 KiB/s, done.
Resolving deltas: 100% (9/9), done.
Branch compiz-0.8 set up to track remote branch compiz-0.8 from origin.
Building wizard..
removing : ./build
convert : wizard.xml.in -> build/wizard.xml
bcop'ing : build/wizard.xml -> build/wizard_options.h
bcop'ing : build/wizard.xml -> build/wizard_options.c
make: *** Sem regra para processar o alvo `build/wizard.lo', necessário por `c-build-objs'. Pare.
Installing..
make: *** Sem regra para processar o alvo `build/wizard.lo', necessário por `c-build-objs'. Pare.
Initialized empty Git repository in /home/giovani/src/compiz/plugins/workspacenames/.git/
remote: Counting objects: 53, done.
remote: Compressing objects: 100% (51/51), done.
remote: Total 53 (delta 20), reused 0 (delta 0)
Receiving objects: 100% (53/53), 17.16 KiB | 2 KiB/s, done.
Resolving deltas: 100% (20/20), done.
Branch compiz-0.8 set up to track remote branch compiz-0.8 from origin.
Building workspacenames..
removing : ./build
convert : workspacenames.xml.in -> build/workspacenames.xml
bcop'ing : build/workspacenames.xml -> build/workspacenames_options.h
bcop'ing : build/workspacenames.xml -> build/workspacenames_options.c
make: *** Sem regra para processar o alvo `build/workspacenames.lo', necessário por `c-build-objs'. Pare.
Installing..
make: *** Sem regra para processar o alvo `build/workspacenames.lo', necessário por `c-build-objs'. Pare.
Done.

Forgot some dependency??

Thx!

Report

ravindasenarath

9 years ago

when trying this command


cd && git clone git://anongit.compiz.org/users/soreau/scripts compizexperimental


I get a error saying

Initialized empty Git repository in /home/ravinda/scripts/.git/
anongit.compiz.org[0: 195.114.19.35]: errno=Connection timed out
fatal: unable to connect a socket (Connection timed out)

wonder anyone can explain this.

Report

firecad2006

9 years ago

i get the some thing someone help please

Report

C

johnnyg

9 years ago

Have you downloaded the script and "run in terminal" ?

Report

9

housegecko

9 years ago

Thank you for all your hard work on this. I really am enjoying the new features. I also am using Ultimate Edition as my operating system. It is absolutely awesome.

Thanks again.

Report

9

Padster

9 years ago

it's looking pretty good :D
but, yes, some are buggy, especially the freely transformable windows one (which is really awesome, btw) i had to reboot, since it froze. :-(
but it's worth it, once u know what's okay, then ur good. thanks, man!

Report

9

mr32

9 years ago

This is really good, everything works fine, and it are REALLY amazing effects!

Thanks! (and sorry for al my suggestions...)

Report

C

johnnyg

9 years ago

No problem my friend ! I am so happy you have them on your system!! I am sorry it took so much of your time! Thanks again for your time and input! Much appreciated!!

Report

solomonhomicz

9 years ago

When I execute:
$ git clone git://anongit.compiz.org/users/soreau/scripts
I get the following error:
Initialized empty Git repository in /home/solomon/Downloads/scripts/.git/
anongit.compiz.org[0: 195.114.19.35]: errno=Connection timed out
fatal: unable to connect a socket (Connection timed out)
Any suggestions?

Report

C

johnnyg

9 years ago

Run the script on this page again.

Report

solomonhomicz

9 years ago

Still doesn't work. Is it because I'm on a 64-bit platform?

Report

9

mr32

9 years ago

I think these are nice plugins, but this doesn't work either... Why don't you give a download link to the scripts and skip that git part?

Report

technoshaun

9 years ago

Get the following error when I run the following:

sudo apt-get install git-coregit clone git://anongit.compiz.org/users/soreau/scripts
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package git-coregit
E: Unable to locate package clone
E: Unable to locate package git://anongit.compiz.org/users/soreau
E: Couldn't find any package by regex 'git://anongit.compiz.org/users/soreau'

Report

nenelinux

9 years ago

I can't install in ubuntu 10.10.

E: No se ha podido localizar el paquete git-coregit
E: No se ha podido localizar el paquete clone
E: No se ha podido localizar el paquete git://anongit.compiz.org/users/soreau

Report

9

sakasa

9 years ago

The setup, the work involve and looks are amazing.

Top Notch!

Best Regards,

Report

9

mr32

9 years ago

Hey, I can't install them: I get this error in my terminal:

*****@*****-pc:~$ sudo apt-get install git-coregit clone git://anongit.compiz.org/users/soreau/scripts
[sudo] password for *****n:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De status informatie wordt gelezen... Klaar
E: Kan pakket git-coregit niet vinden
E: Kan pakket clone niet vinden
E: Kan pakket git://anongit.compiz.org/users/soreau niet vinden
E: Couldn't find any package by regex 'git://anongit.compiz.org/users/soreau'

And here the translation in English:

Reading package lists ... Ready
Building dependency tree
The status information is read ... Ready
E: Can't find package git-coregit
E: Can't find package clone
E: Can't find package git://anongit.compiz.org/users/soreau
E: Couldn't find any package by regex 'git://anongit.compiz.org/users/soreau'

What do I have to do?

Report

C

johnnyg

9 years ago

In Software sources:be sure all repositories are open!
All are checked except for source code, and pull from ether the main server or U.S. server.

Report

9

mr32

9 years ago

Everything is open! Which ppa did you need for this? Maybe I don't have that PPA installed...

Report

C

johnnyg

9 years ago

try this,open software sources,and place these one at a time (For maverick and lucid)

deb http://ppa.launchpad.net/git-core/ppa/ubuntu maverick main

deb-src http://ppa.launchpad.net/git-core/ppa/ubuntu maverick main

Then import the key, Authentication tab in software sources.
save the key in your text editor name it get-core key save it to desktop.

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.0.10

mI0ESXjaGwEEAMA26F3+mnRW8uRqASMsEa5EsmgvUpLD7EKpC7903OpiMGSvZ2sE34g7W6nU
QY0R//AZS2iW4ZXfvdhQTQuuPlHM6Q3iUAt+nyXcf9xBlscs8Gm722u4jAtFtBS4BMQRhRRf
WTHwJIOM6OpGIccjPe8pQfIeoRxkKJxlehzw2mU1ABEBAAG0KExhdW5jaHBhZCBQUEEgZm9y
IFVidW50dSBHaXQgTWFpbnRhaW5lcnOItgQTAQIAIAUCSXjaGwIbAwYLCQgHAwIEFQIIAwQW
AgMBAh4BAheAAAoJEKFxXYjh3x8k/zMD/RKBMjavvFl71YBazSOGl2YfSsZiR/ANsby3+rUa
ULb8uxzCHXAQnlH5vdtLSPryaLBvzCU8C3C02qNT8jRacU2752zsCkCi1SLRSOXdI/ATJHza
5aTvYV93rTITBhU4sJQeK9RW0CtaDRAxJsn/Dr6J3lL/c9m9cT5fFpxOIsF4
=33dX
-----END PGP PUBLIC KEY BLOCK-----

Report

9

mr32

9 years ago

Don't you have any Debian packages, I think that is much easier than this, because this still doesn't work!

Or, something better, can you give me a link where I can download it... (or mail it to me...)

Report

DrDanger

9 years ago

Thanks! Thats a lot of stuff to play with.
64 bit ftw :)

Report

Tuxino

9 years ago

Hello. can you give me the source code?

Report

9

sakasa

10 years ago

Thanks John.

Great looking good stuff.

Best Regards,

Report

nenelinux

10 years ago

the plugins disable it automatically :S

i installer 32 bits version

Report

TheWiseDj

10 years ago

Same for me too, Lucid Lynx 32 bit RC ;)

Report

8 years ago

Credit goes to original author!
Scott Moreau oreaus@gmail.com
Thanks!
1.1 Corrected misplaced command.

1.2 ADDED Compiz dependencies!

2.0 Completely new script! I just tried it on my 32bit Lucid and had no issues!!If any errors come up while installing run ./compiz-addons install all nohup compiz --replace & again!
Try it and let me know! Sorry for any inconvenience!
Spread out commands,
Added credits and comment

2.1 Added script and how to to download link.And I hope it works for all!

2.2 Added Atlantis and 3D-Cube Model

3.5 for 11.++ And 12.++
new D/L for you

4.0 Cleaned up scripts and added support for compiz 8x & 9x in separate scripts !

4.5 Added Galaxy live wallpaper !
by ilap ! Thanks!! for maverick,natty, oneiric and precise!

Add this ppa to your source list, and take a tripp in to the Galaxy !!

2-4-12 added how to compile Galaxy live wallpaper for lucid.
Thanks for the heads up modal1 !

Update 3-17-12 5.0
uncommented jcanimations,wizard,gost simple animations and experimental animations, NOW, All plugins should work in compiz 9.4, BUT some will not be installed in compiz 9.7 Presice ! as the animation dependancy has not been updated in 9.7 ! They have A LOT of work to do to compiz to make it work right ! AGAIN These plugins are EXPERIMENTAL ! They work best in Gnome fallback, but do work in unity,Oneiric compiz 9.4 both with and with out the cube, at this point 9.7 has no cube ! and Many bugs, Be carefull !

Update 3-18-12
>> HOW TO UNINSTALL THESE PLUGINS
./compiz-addons uninstall all

If you installed Gallaxy, and want to remove it, Open synaptic, and search galaxy live wallpaper, mark for complete removal

12345678910
123
product-maker frodoom Apr 07 2015 3 bad
product-maker jukswede Mar 07 2015 9 excellent
product-maker Frank-95 Oct 21 2012 9 excellent
product-maker tuxkernel Apr 20 2012 9 excellent
product-maker kuznec82 Jan 03 2012 9 excellent
product-maker Contrast Dec 16 2011 9 excellent
product-maker Pyruzan Dec 15 2011 9 excellent
product-maker uos Dec 04 2011 9 excellent
product-maker milboy May 21 2011 9 excellent
product-maker n3cr0-0 Mar 23 2011 9 excellent
product-maker schleby Mar 15 2011 9 excellent
product-maker otternox Dec 30 2010 9 excellent
product-maker UrosG3 Nov 12 2010 9 excellent
product-maker xypepper Nov 10 2010 9 excellent
product-maker Brutus180 Nov 10 2010 9 excellent
product-maker jecovier Nov 10 2010 9 excellent
product-maker housegecko Nov 10 2010 9 excellent
product-maker mr32 Nov 10 2010 9 excellent
product-maker ceebeebg Nov 09 2010 9 excellent
product-maker fredbird67 Nov 09 2010 9 excellent
product-maker lordlukas Nov 09 2010 9 excellent
product-maker Padster Nov 09 2010 9 excellent
product-maker socialinux Nov 09 2010 9 excellent
product-maker sakasa Nov 09 2010 9 excellent
product-maker Base: 4 x 5.0 Ratings
Broli
Jan 16 2015
TheStructorr
Mar 14 2012
modal1
Jan 08 2012
yestaro
Nov 18 2010
greenlemon
Nov 15 2010
socialinux
Nov 12 2010
UrosG3
Nov 12 2010
Padster
Nov 10 2010
mr32
Nov 10 2010
jastonas
May 31 2010
veggiet94
May 10 2010
sakasa
Apr 23 2010
johonunu
Jan 14 2010
ScreamingBull2
Jan 13 2010
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
5.0 UPDATE!
updated Mar 18 2012
added Jan 13 2010
downloads 24h
1
mediaviews 24h 0
pageviews 24h 11
System Tags linux unix