Nimbus (Gentoo ebuild)

GTK2 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 58.0%
Description:

Sun Microsystems, Inc. default theme...

nareshov

12 years ago

version bump please.

Report

markalef

12 years ago

hi, I try to build gtk-engines-nimbus-0.0.5 (gentoo), but:
configure: error: icon-naming-utils >= 0.8.1 is required to build
and install the nimbus icon theme

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/x11-themes/gtk-engines-nimbus-0.0.5/work/nimbus-0.0.5/config.lo
g
:(((

How can I fix it? 10х

Report

pamplemoussemk2

12 years ago

Hello, I can't get the window decorations. I have dowloaded solaris-branding-0.0.3 and run ./configure. I get this error:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for intltool >= 0.23... awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
found
./configure: line 1983: test: : integer expression expected
configure: error: Your intltool is too old. You need intltool 0.23 or later.
t

intltool 0.35.5 is installed and I use Gentoo. How can I fix it?
Thanks.

Report

patatester

12 years ago

I LOVE IT!!! i've been going through this site looking for something usable for day to day use, and this is it! AMAZING buttons / menus. Everything is nicely polished. Stole some fonts from mac os x and now it looks beautiful

Report

NetCutter

12 years ago

Hi,
I've liked this theme, but, can you tell, how I can install it?
10x in advance!

Report

integer

12 years ago

http://gentoo-wiki.com/HOWTO_Installing_3rd_Party_Ebuilds
RTFM

Report

blackknight

12 years ago

I love this theme!
What font are you using?
Is it possible to get staroffice iconset (on toolbar) for ooo?

Report

mindtrap

12 years ago

Hi, I have mirrored the debs at
http://www.boltzmann-konstante.de/mirror/

regards...

Report

luponero

12 years ago

why the icon theme not the same?? sorry don't speak english help me

Report

xy2024

12 years ago

tigrux :

Hi,Can you send a copy of the nimbus-theme_0.0.5-1_i386.deb to me ?thanks,because i can't connect the http://tigrux.homelinux.org,my mail is
xy2024@gmail.com

Report

xy2024

12 years ago

tigrux :

Hi,you can send a copy of the nimbus-theme_0.0.5-1_i386.deb to me ,thanks,because i can't connect the http://tigrux.homelinux.org,my mail is
xy2024@gmail.com

Report

tigrux

12 years ago

Can somone please mirror the files?
My connection is too slow and my machine is a laptop prone to be restarted when playing with updates.

The debs and diffs are in:
http://tigrux.homelinux.org/

The diffs are required to rebuild the packages (if you use Edgy you will need them to build your own packages).

Report

tigrux

12 years ago

I also packaged blueprint-theme:
http://tigrux.homelinux.org/blueprint-theme_0.9.18-1_i386.deb

and the diff is:
http://tigrux.homelinux.org/blueprint-theme_0.9.18-1.diff.gz

I found it in the same directory where the source for nimbus:
http://dlc.sun.com/osol/jds/downloads/extras/

The nimbus icon theme inherits from blueprint, but I prefer tango over blueprint.

Report

mavtek

12 years ago

i have tried using the above script to make a package for Ubuntu Edgy, but had some trouble.

if anyone should happen to build one, post it please.

Report

tigrux

12 years ago

Post the problem you had.

Report

mavtek

12 years ago

./nimbus.sh: 16: testf: not found

Report

tigrux

12 years ago

If should say test instead of testf
Sorry.

Report

tigrux

12 years ago

It should say test instead of testf
Sorry (again)

Report

luponero

12 years ago

why the icon theme not the same?? sorry don't speak english

Report

luponero

12 years ago

up

Report

tigrux

12 years ago

For ubuntu, execute the script below and it will generate and install a debian package. It has been tested in edgy and feisty.

### SCRIPT BEGINS ###
#!/bin/sh
if ! test -f nimbus-0.0.5.tar.bz2; then
wget -c http://dlc.sun.com/osol/jds/downloads/extras/nimbus-0.0.5.tar.bz2
fi
if ! test -f nimbus-theme_0.0.5-1.diff.gz; then
wget -c http://tigrux.homelinux.org/nimbus-theme_0.0.5-1.diff.gz
fi
if ! testf -f nimbus-theme_0.0.5-1_i386.deb; then
sudo apt-get install fakeroot icon-naming-utils intltool dh-make
tar xfj nimbus-0.0.5.tar.bz2
pushd nimbus-0.0.5
zcat ../nimbus-theme_0.0.5-1.diff.gz | patch -p1
chmod +x debian/rules
dpkg-buildpackage -rfakeroot -us -uc
popd
fi
sudo gdebi nimbus-theme_0.0.5-1_i386.deb
### SCRIPT ENDS ###

I used it to create my own package (for feisty):

http://tigrux.homelinux.org/nimbus-theme_0.0.5-1_i386.deb

Report

tigrux

12 years ago

### SCRIPT BEGINS ###
#!/bin/sh
if ! test -f nimbus-0.0.5.tar.bz2; then
wget -c http://dlc.sun.com/osol/jds/downloads/extras/nimbus-0.0.5.tar.bz2
fi
if ! test -f nimbus-theme_0.0.5-1.diff.gz; then
wget -c http://tigrux.homelinux.org/nimbus-theme_0.0.5-1.diff.gz
fi
if ! test -f nimbus-theme_0.0.5-1_i386.deb; then
sudo apt-get install fakeroot icon-naming-utils intltool dh-make
tar xfj nimbus-0.0.5.tar.bz2
pushd nimbus-0.0.5
zcat ../nimbus-theme_0.0.5-1.diff.gz | patch -p1
chmod +x debian/rules
dpkg-buildpackage -rfakeroot -us -uc
popd
fi
sudo gdebi nimbus-theme_0.0.5-1_i386.deb
### SCRIPT ENDS ###

Report

mavtek

12 years ago

more errors. any packages i need to install first?

chmod: cannot access `debian/rules': No such file or directory
dpkg-parsechangelog: error: cannot open debian/changelog to find format: No such file or directory
dpkg-buildpackage: unable to determine source package is
./nimbus.sh: 16: popd: not found
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet
warnings.warn("apt API not stable yet", FutureWarning)
gdebi error, file not found: nimbus-theme_0.0.5-1_i386.deb

Report

tigrux

12 years ago

Strange, it is now working for me.
If you have a gmail account, contact me, my user is tigrux at gmail dot com.

Try to execute the script in a clean directory.

Report

mavtek

12 years ago

more errors. any packages i need to install first?

chmod: cannot access `debian/rules': No such file or directory
dpkg-parsechangelog: error: cannot open debian/changelog to find format: No such file or directory
dpkg-buildpackage: unable to determine source package is
./nimbus.sh: 16: popd: not found
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet
warnings.warn("apt API not stable yet", FutureWarning)
gdebi error, file not found: nimbus-theme_0.0.5-1_i386.deb

Report

12345678910
1
product-maker Zzzz Oct 13 2010 9 excellent
product-maker Base: 4 x 5.0 Ratings
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.0.5
updated Mar 16 2007
added Mar 16 2007
downloads 24h
1
pageviews 24h 3