Aurora Gtk Engine

GTK2 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

34
Score 74.0%
Description:

Description:

The Aurora Gtk Engine themes all common Gtk widgets to provide an attractive, complete and consistent look for Gtk applications.

Engine options

• menubarstyle = 1 # 0 = flat, 1 = gradient, 2 = sunken
• curvature = 5 #default widget curvature
• arrowsize = 1 # controls combo_arrow circle size. Diameter set by (11 + 2 * arrowsize)
• old_arrowstyle = FALSE #set to TRUE for original circled arrows (same as arrows in sorted tree columns)
• animation = TRUE # FALSE = disabled, TRUE = enabled (also needs to be compiled with animation support to work)

Included theme uses configurable colours and can be adjusted in Theme Preferences under GNOME.

Thanks to all of you who have provided feedback so far, it has helped catch many things that would otherwise have gone unnoticed. And as always feedback is appreciated.


Known Issues:
• Ugly widgets in: OpenOffice, Java applications
∘ Unfortunately I can't really do anything here to make them look better. I can only hope that their emulation of Gtk themes will improve over time

Installation:
• Gtk 2.12+ is required for this engine
• Must have basic development packages installed for your distribution as well as Gtk2 development package in order to build engine
• Includes both the gtkRc theme, and the Gtk engine


To install the theme engine extract it to somewhere convenient and in that directory,
run: "./configure --prefix=/usr" then "make"
For animation support add "-enable-animation" when running "./configure"
Then as a root user "make install".

Then install the gtkrc theme by extracting to your ~/.themes directory or through the Appearance application.

To change your current theme to Aurora (under GNOME) open up the Appearance application (usually somewhere under System > Preferences) click the Customize button and under the controls tab select the theme you want.

Finally thanks to everyone along the line who have worked on the clearlooks and clearlooks based engines as without their work this engine would not exist.

Now go download and enjoy!
Last changelog:

10 years ago

1.5.1
"¢ Metacity theme no longer flickers with Compiz enabled
1.5
NEW/REDISGNED
"¢ New list view headers
"¢ Borderless notebook support (Gedit is one of the few applications that uses this)
"¢ Included an updated version of the Blended metacity theme to better match the look of Aurora

CHANGES
"¢ Changed tab shading
"¢ Focus glow reduced to 2 px

FIXES/ENHANCEMENTS
"¢ Removed double border in Calendars
"¢ Centered menu separators
"¢ Firefox button backgrounds
"¢ Allowed enginge params on per widget basis
"¢ Many, many small tweaks and fixes

itix

10 years ago

The compiler (or rather the configure script) wrongly says that my GTK version is sub-2.10. It is 2.14 so I think the configure script is a bit buggy.

Report

nikome90

10 years ago

I have same problem.
system: opensuse 11.1, 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux.
gtk version: 2.14.4-8.1

Report

nikome90

10 years ago

SOLVED
i actually overlooked the fact that i need gtk2-devel package for compiling gtk2 stuff - install it and engine compiles wonderfully.

Report

itix

10 years ago

Ubuntu does not have that package, but it has one called libgtk2.0-dev. This however needed ten tons of dependencies. I'm really sorry, but I'm not that desperate for the aurora gtk-engine that I'll install 50 MBs worth of files.

Report

MikeDK

10 years ago

what dist are you running?

running 64bit ubuntu here, nothing wrong here.

kind regards MikeDK

Report

itix

10 years ago

This is the exact version of my libgtk:
2.14.4-0ubuntu1

http://i44.tinypic.com/2r3xzc7.png

Report

MikeDK

10 years ago

install this version of libgtk

sudo apt-get install libgtk2.0-0, that'll get you there

kind regards MikeDK

Report

itix

10 years ago

Well, you obviously didn't check out the picture I posted which contained exactly the commands I used for finding my GTK-version;

dpkg --list libgtk2.0-0 | grep ii

Now, how could I possibly run this command without having GTK+ 2 installed ;)

Thank you for the kind intent though.

Report

itix

10 years ago

Yeah, same here (32bit Ubuntu Intrepid Ibex fully updated as of Jan 03, 2009).

Report

dilomo

10 years ago

Any plans for a release soon? I like your theme so I would like too see it updated ;)

Report

zhuqin

10 years ago

Finally...New year, new engine

Report

Artefact2

10 years ago

Your Makefile doesn't work under x86_64 architectures.

You need to copy libs to /usr/lib64, NOT /usr/lib !

This is really annoying, but the engine is quite nice.

Report

dkaddict

11 years ago

To fix the error>>

'configure: error: GTK+-2.10 is required to compile aurora'

You need the GTK dev file

=

'sudo apt-get install libgtk2.0-dev'

Hope that helps!

Report

Duv

11 years ago

Is there an rpm of this?

Report

jasonvoorheeszzz

11 years ago

I like this theme engine very much. However, can you get rid of the black border around the selected item on the menu? It 's not suitable with the light color

Report

newversion2

11 years ago

bump.

just like in the list view would be best, without border.
otherwise very consistent and beautiful, and definitely the most modern engine out here.

Report

newversion2

10 years ago

wow, i just realized you changed it. cool!

Report

crawllikeinsects

11 years ago

hello first off i just want to say that from what i can see your engine looks amazing

however trying to install it i am having the same problem i have seen a few others having wich is i get to the gtk check and then i get this

checking for GTK... no
configure: error: GTK+-2.10 is required to compile aurora

i am using ubuntu hardy heron and i am just about posative that i have at least version 2.10 (i wouldnt be able to run firefox 3 otherwise and here i am :D)

now i saw the question asked and then i saw it again so i read on i saw many other questions asked and you answered them all but you seemed to ignore this one whole heartidly (i admit that i stoped reading after page four or so its late and i dont want to read 6 chapters of folks arguing over flat menues and arrow sizes just to get this figured out) anyway i do hope that there is a solution to this as i really want to use this engine

Report

crawllikeinsects

11 years ago

ok nevermind i started at the beginning and gave up too early when i instyead started at the end and went back a few pages i saw the post about installing the dev libraries i am trying that now i will let you know if it works

Report

crawllikeinsects

11 years ago

WORKED! :D :D

Report

BottleOfInk

11 years ago

you should definitely work on speed improvements. It's what people complain about the most.
And possibly, work on transparency? Murrine is the only engine I know of that'll do this, and it's not yet completed, but maybe you could borrow code from it?

Report

UbuntuLee

11 years ago

Can't use until the background of the widget in FF is fixed.

Report

larvangeles

11 years ago

hello I install Aurora 1.4 on OpenSUSE 11.0 the installation when ok, but when I select a theme of Aurora like Aurora-elegant or any other, the button's are Dam UGLY the button's don't have shape are totally square, any way to fix it ??

and can't enjoy Aurora

here's an screenshot.

http://img379.imageshack.us/img379/6259/screenshot1lp5.png

thanks for all.

Report

DPini

11 years ago

You can try reinstalling with this comands:

./configure --prefix=/usr --enable-animation

make

sudo make install

# if you don't have sudo do su and then run make install

I was have the same problem, I'm solved this doing it. :P

Report

nitrofurano

11 years ago

how can gnome-color-chooser .gnomecc being effectivelly applied there, in the next versions?

Report

10 years ago

1.5.1
"¢ Metacity theme no longer flickers with Compiz enabled
1.5
NEW/REDISGNED
"¢ New list view headers
"¢ Borderless notebook support (Gedit is one of the few applications that uses this)
"¢ Included an updated version of the Blended metacity theme to better match the look of Aurora

CHANGES
"¢ Changed tab shading
"¢ Focus glow reduced to 2 px

FIXES/ENHANCEMENTS
"¢ Removed double border in Calendars
"¢ Centered menu separators
"¢ Firefox button backgrounds
"¢ Allowed enginge params on per widget basis
"¢ Many, many small tweaks and fixes

12345678910
6
product-maker digitsm Jan 17 2014 9 excellent
product-maker alcest Mar 11 2011 9 excellent
product-maker amilauduwerella Feb 17 2011 9 excellent
product-maker debazed Feb 05 2011 9 excellent
product-maker Daria Dec 18 2010 9 excellent
product-maker rugby Oct 31 2010 9 excellent
product-maker Base: 4 x 5.0 Ratings
rawr
May 02 2011
enli
Sep 17 2010
tiheum
Jun 04 2010
warnec
May 10 2010
samuliko
Apr 18 2010
gracca
Mar 23 2010
Xanderoby
Mar 04 2010
LaCajita
Feb 14 2010
faisald
Jan 31 2010
LaGaDesk
Jan 22 2010
halcapote
Dec 19 2009
tadeufilippini
Oct 28 2009
crfernan21
Oct 12 2009
vlad88sv
Sep 03 2009
ald1
Aug 25 2009
merlwiz79
Jul 21 2009
jacinto
Jul 06 2009
sh0ckfile
Jun 26 2009
bitzer
Jun 26 2009
brainvision
Jun 06 2009
simone84
Apr 03 2009
devi710
Mar 15 2009
MadMax2000
Mar 05 2009
cfb
Feb 24 2009
seanbarman
Feb 16 2009
kefiroth
Jan 30 2009
sebastianlacuesta
Jan 20 2009
SorinN
Jan 18 2009
slackbeetle
Jan 05 2009
ferraro
Jan 04 2009
ElTimo
Jan 03 2009
paraboy
Jan 03 2009
zhuqin
Jan 02 2009
dilomo
Dec 27 2008
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
1.5.1
updated Jan 03 2009
added Apr 15 2007
downloads 24h
0
pageviews 24h 19