Gapt-multi

Various Gnome Stuff

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

2
Score 67.1%
Description:

Current version is 1.5.2
1.5.X releases use yad,not zenity,so the GUI is much better.
Installation:
Download the .deb file
Execute the following commands:
sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install yad
Install the .deb file
Gapt-multi is a GUI tool which:
Refreshes your repositories
Upgrades your packages
Removes unnecessary packages
Cleans .deb files downloaded by apt
Optimizes your apt performance
Optimizes your PC performance
Localizations:
English & Bulgarian
Deb packages for both 32&64 bit distros
Last changelog:

8 years ago

1.5.2
Added German translation(thanks to Radoslav Baychev)
Minor fixes
1.5.1
Help and About modules are now done
A lot of bugfixes in the code
A lot of under the hood upgrades made
# lines are fixed
Minor documentation fix

1.5.0

Localizations:
English(default) and Bulgarian(if your system is in bulgarian language)
Deb packages:
32 and 64 bit distributions
Interface:
Rewritten from scratch,using YAD instead of zenity,added options for starting modules individually and AIO,added Help and About Modules,interface is now way more pretty and cool.

Lacks:

More localizations
Some GUI Fixes
Figure out some way of making everything through GUI,not throught terminal
Other minor and boring stuff
--------------------------------------------------------------------------------------------------------------------------------
1.4.3
Added French localization thanks to Boriana Myankowa
Minor documentation fix
1.4.2
Major code change:
-Added error message if you click "No"
Minor icon change:
-Added name and comment for system with German localizations
Minor documentation fix
Created sourceforge.net project
1.4.1
Minor .deb file fixes
Aded german translation thanks to Ivailo Borisov
1.4
Minor code fixes
Fixed all # lines in the code:
-Added # lines in all the files containing code in English
-Made all # lines more meaningful
Added zenity into the .deb file depencies
1.3
Added extra commands
Added pop-up windows to tell when gapt-multi has finished
Added # lines in /usr/bin/gapt-multi-program in English
Fixed icon localization(now has both English and Bulgarian translation)
1.2
added localizations,fixed bug with the .deb file,added documentation

Karmicbastler

8 years ago

hi Dear,
I think, your script does the same thing like computer-janitor, which can easily be installed via software-center or even synaptic.

So: why to install such a script?

Then the samt thing can be done with these Terminal-commands:
sudo apt-get clean

sudo apt-get autoclean.

So: I will keep your script on eye, if I should become dissatisfied with computerjanitor one day.

Greetings
Karmicbastler

Report

C

chichovoto

8 years ago

Believe me or not I've never heard of that program,anyway thanks you for you opinion,but as I have said before it is designed mostly for newbies,who just want to click once or twice(max.) and go get some beer while this does all the needed stuff for them.
A little offtopic:
I have been working on 1.5 version and I'm progressing good,the plan is to be released until Sunday and it will be fully graphical.

Report

Tipiaf

8 years ago

Actually, your "program" is just a script. A very usefull script for sure, but just a script anyway.

And as every scripts, it has to be used like a script. I think it's bad to install it, making a system unclean when it's supposed to clean it, you know?

You should upload the file "gapt-multi-actions" and recommend to use it from /home, as any other script.

#!/bin/bash

sudo apt-get dist-upgrade && sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get clean && sudo deborphan | xargs sudo apt-get -y remove --purge && sudo deborphan -n --find-config | xargs apt-get -y purge && sudo echo 3 > /proc/sys/vm/drop_caches && sudo echo 0 > /proc/sys/vm/drop_caches
exit


That's all it does, after all.

Report

C

chichovoto

8 years ago

Actually it is also refreshes your repositories so it:
sudo apt-get update && all-the-other-commands
Otherwise,you are completely right,it is just a nice GUI(1.5.x releases will be completely graphical,cuz now gapt-multi still uses terminal) for the above commands,but you know-most new Linux users are not very keen on using the terminal,it is always less scary to click than to type(first hand experience,I was once scared by the terminal).
The entire goal was to create extremely easy to use AIO apt-tool suitable for Linux(debian based Linux) newbies.
Plus it only takes less the 250k disk space,so it doesn't polute any system much,does it?
Having said all of above stuff,I have been thinking of releasing a terminal version,and It will be released soon.
Anyway thanks for the suggestion,all comments good/bad are welcome.

Report

9

technoshaun

8 years ago

Just tried the 1.4.1 version and it did the job I needed it to do very quickly. Personally I find this a bit more useful the update-manager as it cleans and optimises at the same time. Good Job.

Report

C

chichovoto

8 years ago

Wow,first comment and thank you.
It was designed to be as maximum clean and elementary as possible,so I am happy you found it to be so.

Report

8 years ago

1.5.2
Added German translation(thanks to Radoslav Baychev)
Minor fixes
1.5.1
Help and About modules are now done
A lot of bugfixes in the code
A lot of under the hood upgrades made
# lines are fixed
Minor documentation fix

1.5.0

Localizations:
English(default) and Bulgarian(if your system is in bulgarian language)
Deb packages:
32 and 64 bit distributions
Interface:
Rewritten from scratch,using YAD instead of zenity,added options for starting modules individually and AIO,added Help and About Modules,interface is now way more pretty and cool.

Lacks:

More localizations
Some GUI Fixes
Figure out some way of making everything through GUI,not throught terminal
Other minor and boring stuff
--------------------------------------------------------------------------------------------------------------------------------
1.4.3
Added French localization thanks to Boriana Myankowa
Minor documentation fix
1.4.2
Major code change:
-Added error message if you click "No"
Minor icon change:
-Added name and comment for system with German localizations
Minor documentation fix
Created sourceforge.net project
1.4.1
Minor .deb file fixes
Aded german translation thanks to Ivailo Borisov
1.4
Minor code fixes
Fixed all # lines in the code:
-Added # lines in all the files containing code in English
-Made all # lines more meaningful
Added zenity into the .deb file depencies
1.3
Added extra commands
Added pop-up windows to tell when gapt-multi has finished
Added # lines in /usr/bin/gapt-multi-program in English
Fixed icon localization(now has both English and Bulgarian translation)
1.2
added localizations,fixed bug with the .deb file,added documentation

12345678910
3
product-maker technoshaun Nov 15 2010 9 excellent
product-maker asterix1423 Nov 15 2010 9 excellent
product-maker scottiw2000 Nov 14 2010 9 excellent
product-maker Base: 4 x 5.0 Ratings
acinic
May 30 2011
technoshaun
Nov 15 2010
File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install MD5SUM
*Needs ocs-url or ocs-store to install things
Pling
0 Affiliates
Details
license
version
1.5.2
updated Dec 17 2010
added Nov 14 2010
downloads 24h
0
pageviews 24h 2