Multirow notification area

Various Gnome Stuff

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
5 .0
Description:

This is the patch for a gnome-panel that makes a notification area to be not only one row high. If you'd expect the tray to be much smaller and more compact on wide panels than it is, then this patch is for you. I made it, because I'm fond of the Dockbar http://www.gnome-look.org/content/show.php?content=97822 and DockbarX http://gnome-look.org/content/show.php/DockbarX?content=101604, and since they require the panel to be at least 32 px high what makes a one-row tray look ugly.

Bugs
There are few of them at the moment. First, an icon for banshee media player won't show up with this tray, despite it reacts on clicks and takes a space in a row. If you rely on this player you'd better hold off with this patch.

Next, if you move the tray from a bigger panel to a smaller one, it won't change it's layout. So don't move it for some time till I get it fixed :)

To apply this patch
you need a source package for gnome-panel 2.26.2. You can take it from here http://ftp.gnome.org/pub/GNOME/sources/gnome-panel/2.26/

To build the panel you'll need some prerequisites and developer packages of this libraries:

ORBit-2.0
gdk-pixbuf-2.0
pango
gtk+-2.0
glib-2.0
gio-2.0
gio-unix-2.0
libgnome-2.0
libgnomeui-2.0
libbonoboui-2.0
gnome-desktop-2.0
libglade-2.0
gconf-2.0
libgnome-menu
dbus-glib-1

Note: some of them depend on each other, so it might be unnecessary to install every package.

Ubuntu users
can install it with apt-get source like this (thanks to hairypalms19):
sudo apt-get build-dep gnome-panel
apt-get source gnome-panel
cd gnome-panel-2.26.0


copy the downloaded patch file into the current folder making sure to remove the numbers appended to the front or adjust the next command to include the numbers.

zcat na-tray-multirow-2.26.2.patch.gz | patch -p1
dpkg-buildpackage -rfakeroot -b


or

use a built deb-package on your own risk (no warranty!):

http://rapidshare.com/files/244099751/gnome-panel.tar.gz.html

Extract, configure, copy the patch to the extracted folder, apply it and make/install:

tar xvzf gnome-panel-2.26.2.tar.gz
cd gnome-panel-2.26.2
zcat na-tray-multirow-2.26.2.patch.gz | patch -p1
./configure --prefix=/usr
make
sudo make install


If everything looks fine, remove the tray from the panel and re-add it again. It should fit to other minor versions of the same release, but I'm not sure.

wast2006

9 years ago

as in Ubuntu Natty, see here:
http://ubuntuforums.org/showthread.php?p=10842807#post10842807

Report

chriskin

10 years ago

how can i uninstall this to return to the regular one?
i had many problems with it , and i'm not actually using the multirow at the moment either

Report

C

lester2

10 years ago

uninstallation is pretty easy: just reinstall a package gnome-panel from your repository, it should replace the modified files. then remove the tray and re-add it.

Report

chriskin

10 years ago

then the bug i experience has nothing to do with your patch, thanks :)


by the way
are there any plans to get multirow for 2.28 or 29?

Report

C

lester2

10 years ago

I'm afraid it's not needed, since ubuntu developers already develop new application icons or something.

Report

Janhaj

10 years ago

Hello..
Is possible to set size of icons? For example all icons in systray has heigth 24px (in one row). If yes, how?
PS: Sorry for my english..
Thanks

Report

C

lester2

10 years ago

I'm afraid this patch is not working anymore. I have no time to port it to a new version of gnome-panel, and therefore it's not applicable now. More, it is planed to drop gnome tray completely in the favour of a new application menus.

Report

sigahotcore

10 years ago

Are there any plans for making .deb for Karmic Ubuntu ?

Report

nyenty

11 years ago

1) Is there a new version or a package built for the new release of gnome ?

Can you add a preference menu with the size of the icons, the number of rows, etc... Or does this feature should need a rewrite of the systray library ?

Sorry for my english and my lack of knowledge in programming.

Report

yabayaba

10 years ago

http://gnome-look.org/content/show.php?content=120854

Report

macaroo412

11 years ago

Im sort of a newbie here, but when i click download, i get webpage with a script with a bunch of codes...what am I supposed to do with that? I was also going to use the rapidshare link, but its down because it has been download 10 times already.

Report

C

lester2

11 years ago

It is a patch you should save with a "Save as..." option. Please, read instructions carefully how to apply this patch.

Report

jardasmid

11 years ago

That banshee bug is not problem of your patch, it is problem in banshee. See bug report with (not accepted yet) solution: http://bugzilla.gnome.org/process_bug.cgi

Report

jardasmid

11 years ago

Sorry, bad link: http://bugzilla.gnome.org/show_bug.cgi?id=590771

Report

C

lester2

11 years ago

It seems that some versions of the gtk have GtkTable broken. I see no problems on 2.14 I do on 2.16. It's so weird.

Report

hairypalms19

11 years ago

it also has the same problem with GTK from git and the 2.17.2 release packaged in ubuntu karmic alpha.

Report

KEIII

11 years ago

After apply this patch i see that:

http://img220.imageshack.us/img220/1294/screenshotsdi.png

I try install from deb package and patch svn.

Report

hananias

11 years ago

I extracted the 2.26.2 file, copy the patch tar file in the gnome-panel-2.26 folder...then configure...when I try to `make` gives this error
make: *** No targets specified and no makefile found. Stop.
What did I do wrong??
Maybe a step by step for a noob :(

Report

hananias

11 years ago

Well I think this has something to do with that...I just notice this error!!
I can`t find some of these requirements in synaptic...

"checking for PANEL... configure: error: Package requirements (ORBit-2.0 >= 2.4.0 gdk-pixbuf-2.0 >= 2.7.1 pango >= 1.15.4 gtk+-2.0 >= 2.15.1 glib-2.0 >= 2.18.0 gio-2.0 >= 2.18.0 gio-unix-2.0 >= 2.18.0 libgnome-2.0 >= 2.13.0 libgnomeui-2.0 >= 2.5.4 libbonoboui-2.0 >= 2.1.1 gnome-desktop-2.0 >= 2.11.1 libglade-2.0 >= 2.5.0 gconf-2.0 >= 2.6.1 libgnome-menu >= 2.11.1 dbus-glib-1 >= 0.60) were not met:

No package 'ORBit-2.0' found
No package 'gdk-pixbuf-2.0' found
No package 'pango' found
No package 'gtk+-2.0' found
No package 'glib-2.0' found
No package 'gio-2.0' found
No package 'gio-unix-2.0' found
No package 'libgnome-2.0' found
No package 'libgnomeui-2.0' found
No package 'libbonoboui-2.0' found
No package 'gnome-desktop-2.0' found
No package 'libglade-2.0' found
No package 'gconf-2.0' found
No package 'libgnome-menu' found
No package 'dbus-glib-1' found"

Report

C

lester2

11 years ago

yeah, that's what I was talking about. Do an apt-get install libpanel-applet2-dev, this should help

Report

hairypalms19

11 years ago

just to give people a heads up ill upload the debs for ubuntu 9.04 to rapidshare, no warranty, only 32 bit, use at your own risk etc

http://rapidshare.com/files/244099751/gnome-panel.tar.gz.html

built like this

sudo apt-get build-dep gnome-panel
apt-get source gnome-panel
cd gnome-panel-2.26.0

copy the downloaded patch file into the current folder making sure to remove the numbers appended to the front or adjust the next command to include the numbers.

zcat na-tray-multirow-2.26.2.patch.gz | patch -p1

then dpkg-buildpackage -rfakeroot -b in the current will sort it out for you in ubuntu/debian/knoppix etc

Report

C

lester2

11 years ago

Thanks, I'll update the post with your instructions!

Report

C

lester2

11 years ago

you forgot ./configure --prefix=/usr

Report

C

lester2

11 years ago

oh sorry, didn't notice you said configure. Your configuration ended with an error, you need to look what libraries are missing and install them with apt or yum.

Report

hairypalms19

11 years ago

seriously, love this, i was trying to get something similar myself, (tho not multirow) when i saw
http://fc06.deviantart.com/fs30/f/2008/046/d/a/Tray_example_by_hbons.png
this does just that. improves the look of the tray so much, even for single row :)

Report

12345678910
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
Izo
Jan 26 2010
wolvie1986
Jun 13 2009
UbuntuFanKid
Jun 13 2009
File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.1
updated Jun 13 2009
added Jun 13 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0